CS won’t let me create history states or reopen files…HELP?

Posted By
Nov 28, 2003
I keep having this issue: I try to open a .PSD file I’d been working on (several different ones),and get an error message saying "Can’t complete request due to a program error…" I’ve also had this message after closing & trying to reopen a file after not being able to create history states…has ANYONE seen this???


Must-have mockup pack for every graphic designer 🔥🔥🔥

Easy-to-use drag-n-drop Photoshop scene creator with more than 2800 items.

Nov 28, 2003

Do you have any Symantec products on your system (Norton Utilities, SystemWorks, Anti-Virus, etc.)?? I’ve not yet found anything conclusive to say that any of these are causing problems but, if you do have them installed, you might try removing them to see if that helps.

I say this becuase, in addition to random aborts of PSCS that I see when trying to access the Photoshop Help or (new) the Welcome Screen, I have seen numerous random errors of the nature you report when selecting the Open or New commands, as well as once with a Close. Adobe hasn’t been able to duplicate my problems as yet, and I feel I’m grasping at straws to find the cause.

My latest news is that even on a rebuilt system without any Norton apps installed and the registry cleaned of any remnants, I feel as if the problem with the Help menu has improved, but I still get the program error messages. Usually this has come after exercising many successful attempts at opening the Help menu and then moving off to some other command.

I know Adobe isn’t have much luck with my specific problem, yet more and more I’m feeling as though the cause is rooted in PSCS. I’ve not given up the fight to identify any problem caused by my system however.

Good luck with finding an answer,

Nov 28, 2003
thanks Daryl,
yes, I have SW2003 installed…I’ll try dumping it today, though I hate the idea of being naked as far as virus protection ..I’m just glad I’m not the only one having this issue–

the only other compatibility issue I’ve had so far is with my SanDisk card reader not working properly with a certain update for Roxio CD Creator 5 installed. Sandisk had a patch, and it’s solved. I can only hope Adobe gets something like this in the works!
thanks again.,
Nov 28, 2003
I really don’t think Norton AV or Norton Firewall are a problem with Photoshop CS. I’m running all on two machines and have had no problems whatsoever. Obviously doesn’t mean they might not be prblematic on someone else’s machine but I haven’t seen any reports of any problems. The Norton Utilites may be more suspect from what Daryl said a few days ago.
Dec 24, 2003
I receive the same "Could not complete your request because of a program error" message when creating a simple file, closing it, then try to open it again.

I have a Brand New Dell XPS 3.2 GHz EE, 2 Gb RAM, SATA RAID 0, Radion XT PRO 256 Mb and a secondary UDMA 80 Gb. XP Pro, PSCS and McAfee Internet Security version 6 is all I have running. I disabled everything I can in McAfee without being naked and I thought it was my 80 Gb hard drive, so I moved my swap files and PSD locations. I tried creating a new file and same thing. I’m afraid to open any archived PS files for fear of corrupting them, besides backing them up to DVD.

Is there any news on this yet?
Dec 24, 2003
In version 7 that error could usually be cleared by resetting the prefrences.

Mathias Vejerslev "How to delete/reset Photoshop preferences" 2/11/03 12:04pm </cgi-bin/webx?50>

Jury’s still out on how well that works in version 8 (CS).

Good luck, dave
Jan 1, 2004
Fixed it! Just reinstalled Adobe CS and could again open my files once thought corrupt. Probably could have tried the less aggressive approach of resetting preferences. Back to work (or having fun). Happy New Year…
Jan 2, 2004
I have been getting this message a lot since installing CS. I get it when trying to save a file most often.
Yesterday I got it when trying to flatten an image. I also couldn’t save it. Then I cropped it and I was able to flatten and save. Today I got it after printing a file, then opening another from the file browser and trying to print the second one.
I’m running Win 2000 and have 768 Megs Ram and over 8 Gbytes free disc. Mostly seems to happen with larger files, but today’s printing was nothing especially big.
Jan 15, 2004
have a workaround : have deleted the preference folder

the image opens !!!!

have edited my preferences (one item then open, an another one and open, etc…)

It seems the error occurs when i change the cache level value.

Must-have mockup pack for every graphic designer 🔥🔥🔥

Easy-to-use drag-n-drop Photoshop scene creator with more than 2800 items.

Related Discussion Topics

Nice and short text about related topics in discussion sections