Posted By
Aug 10, 2008
I have downloaded the trial version of Adobe Photoshop, when I ever I run the exe, it successfully creates the folder for CS3.

Upon doing this, I access the setup.exe file and run it.

It completes on 100%, and then says;

‘You can only install one Adobe product at a time. Please complete the other installation before attempting to install Adobe Setup.’

I only have reader and flash on my computer, I have searched for this other incomplete installation and have found nothing.

The system is in error as there is no other program installing or running.

What then, is the solution to this issue? How do I get photoshop to complete it’s installation?


There is a screenshot of the fail screen.

How to Improve Photoshop Performance

Learn how to optimize Photoshop for maximum speed, troubleshoot common issues, and keep your projects organized so that you can work faster than ever before!

Aug 10, 2008
Hit Ctrl Alt Delete to bring up the Windows task manager. Look to see if there are multiple processes or applications running. I know some virus will make a hidden iexplore (Internet Explorer) always run in the background, and perhaps something of the type is happening with an Adobe installer.
John Joslin
Aug 10, 2008
This was reported a few times after CS3 came out.

I can only suggest the various steps that were recommended then, which included a full removal from the Control Panel applet followed by a deletion of all folders (in several directories) related to CS3, then running the Adobe clean-up script, then re-installing.

There were other problems related to AV, Flash, IE and registering a DLL too.

All in all, it makes you long for the day when an installation routine worked properly. This is another example of Adobe rushing an incomplete, buggy program out to meet marketing time-scales rather than engineering ones. As long as they go on making obscene profits things are not likely to change either.
Jan 14, 2009
I wasn’t able to remove it from Add/Remove programs because the "Change/Remove" button was missing. Instead, I went straight to the Adobe clean-up script and it worked flawlessly. Now I was able to reinstall photoshop and remove it, getting rid of (hopefully) all traces of the program.

Here is a link to the clean script program

MacBook Pro 16” Mockups 🔥

– in 4 materials (clay versions included)

– 12 scenes

– 48 MacBook Pro 16″ mockups

– 6000 x 4500 px

Related Discussion Topics

Nice and short text about related topics in discussion sections