PS CS4 Display lag and missing marching ants!

KS
Posted By
Kaustav_Saikia
Oct 24, 2008
Views
1516
Replies
24
Status
Closed
I just installed a trial version of PSCS4-Extended, I donot have a GPU instead depend on the inbuilt Intel solution for display (onboard). I have plenty of RAM (2GB) running Vista Ultimate.

1. All the menu items are grayed out upon launch, this can be corrected by clicking on one of the tool icons.

2. Whenever I use a marching ants based tool (magic wand, marquee etc) The display does not update to reflect the selection. One has to click on another tool icon or move the window and then it shows. Also, the marching ants are no longer "marching" but its kind of a dashed line selection.

3. The thumb in the palette window becomes garbled upon any work done on that layer.
JH
Jeff_Holmes
Oct 24, 2008
I have extended as well, but I haven’t noticed what you describe. The marching ants selection is different – the ants are bigger – and the transform lines seem to be invisible between adjustment points which will take some getting used to, but maybe there’s an adjustment somewhere.

I haven’t had anything garbled though. Everything is pristine and pure gold so far.

Maybe a complete uninstall and reinstall?

Jeff
DM
dave_milbut
Oct 24, 2008
I would update your video drivers first…
CC
Chris_Cox
Oct 24, 2008
2 and 3 – video card, update the driver.
Oct 25, 2008
have the same problem. i have latest updates of my video card Nvidia geforce 7600 GT, 4Gb ram, Intel Core 2 Quad CPU 2.66, Windows XP SP3. (with photoshop cs3 no problems)

I have problems with showing layers after I move them. When i hide or show some layers the changes will show only after i click somewhere in the window or select another tool . like photoshop window redrawing have some pause or big delay.
KS
Kaustav_Saikia
Oct 28, 2008
oh well….i DONOT have a GPU, as mentioned in the OP. so no video cards….
Oct 28, 2008
its dont metter the lag is when GPU is OFF and GPU on 🙁 in both modes the same…
WH
Wes_Halton
Nov 5, 2008
I have the same problem, plus if I merge layers the thumbnail of the resulting layer becomes a blank rectangle with small hatching

The marching ants can be restored by zooming in and out after using a selection tool .. not exactly best way to work !

My video card does not support GPU and its turned off in the preferences.
KS
Kaustav_Saikia
Nov 5, 2008
I found the Solution:
If you open CS4 first and then any PSD file then this prob happens. However if you click on any existig PSD file (and hence open PS alongwith the file) the error doesnot happen!
P
ProArtist
Nov 5, 2008
Consider yourself lucky that you dl’d the trial. Avoid photoshop CS4, stick with CS3 if you value performance. CS4 is flat out terrible (even on the latest hardware)
JJ
John Joslin
Nov 5, 2008
No it’s not!

Loads and runs fast; wonderful new features. A photographer’s dream!
P
ProArtist
Nov 5, 2008
Are you paid by Adobe to be a cheer leader? 😉

I’m curious what resolution you run CS4 at and on which hardware because on a 30 inch monitor, at 2560×1600… CS3 beats the pants off CS4.
DM
dave_milbut
Nov 5, 2008
Are you paid by Adobe to be a cheer leader?

are you paid by a competitor to trash the app? that’s what it looks like from here. if you want help, post a question and frame it in a positive way without any rancor. many people here help out every day for the sake of helping. but when you waltz in and start smacking down the app we use and love (and hate at times) we get defensive.

just saying you’ll get more helpful reaction and advice in this USER TO USER forum by remaining positive (even in the midst of your system problems) than by being a d*ck.
P
ProArtist
Nov 5, 2008
blah blah… blah.

I was being tongue and cheek cause he posted the same thing in another thread. I asked him a real question. I wasnt being just a d*ck.

Oh and yes… I am dissapointed in CS4 and none of you have any of the answers as to why it performs badly.

Not a competing company… there are no competitors to photoshop. Unless you consider Corel a competitor… I dont. They suck. There… see.. i’m not a competitor.
DM
dave_milbut
Nov 5, 2008
and none of you have any of the answers as to why it performs badly.

we’re users. we’re here to learn. we’re learning with everyone else. as fixes become available from various sources we let other users know. you CAN pay for support from adobe directly if this setup doesn’t meet your approval.

here are no competitors to photoshop. Unless you consider Corel a competitor… I dont. They suck. There… see.. i’m not a competitor.

well fair enough then. carry on. 😉

edit:

I was being tongue and cheek cause he posted the same thing in another thread.

yet you missed my own tongue in cheek when you’ve posted similar in other threads? oh, the irony! 😉
M
masterk999
Nov 14, 2008
OK, I started doing exhaustive testing and when I removed all my plugins from the plugin folder (leaving only adobe installed files). All my speed problems went away@! so one by one I put my plugins back and the culprit turned out to be Dfine2 from Nik software. <http://www.niksoftware.com/dfine/usa/entry.php>

I had slow screen updates and layer updates with both brushes and text. My simple test was open reasonable sized file, say 250k jpeg, then make a new layer and fill that layer with black. When I was having the problem it would take forever for the screen to update and the layer pallete thumbnail always showed a checkerboard. Once the offending plugin was removed everything became instant again.

I hope this helps someone.
G
Gener
Nov 14, 2008
I’m having no problems with CS4 and it does. Added that to "latest drivers" advice,and DirectX updates.
CF
chris_farrell
Nov 14, 2008
ProArtist

I’m running a dual monitor set-up, 30" @ 2560×1600 and a 24" @ 1920 x 1200 with a 8800gts 640mb card. Both CS3 and CS4 are working well!

Have you tried a reformatted yet?…all those issue might just disappear.
DH
Dennis_Hallinan
Nov 16, 2008
My XPproSP3 box had same problems with CS4Extended: display lag and marching ants that require dragging to be seen. Weird. Nvidia Quadro FX 4500 video card. Updated the driver: no change.

Dennis Hallinan
KS
Kaustav_Saikia
Dec 2, 2008
Problem solved. removed all 3rd party plugins. It works like a charm now. now i will install the plugins one by one and see which one is the culprit. Oh BTW — PSCS4 works very fast on Windows 7!
JJ
John Joslin
Dec 2, 2008
😉 @dave
MD
Michael_D_Sullivan
Dec 28, 2008
BTW, there is a recent update to Nik’s dFine2. I have it and have not experienced any slowness.
CC
Chilkoot_Charley
Jan 25, 2009
It doesn’t help. I have updated the drivers for a NVidia 7800 GTX with Vista…. CS2 has no such issues but in 4 everything is slow and laggy like trying to drag an existing marquee outline from one side of a relatively small 23MB file to the other. You lose the marquee from 1-2 seconds and have no idea where it’s going to end up. It’s nearly impossible to modify a file that way. Seems like a small issue but it’s very aggravating.
WE
Wolf_Eilers
Jan 25, 2009
C Charley, have you set the NVIDIA 3D settings to Performance?
SS
Steve Sprengel
Jan 25, 2009
On my 1GB 2.4GHz single-core AGP system, I had the issue of the marquee disappearing whenever I had the OpenGL enabled because my video-card was too old and slow, an nVidia 6200, so I just shut off OpenGL and while the display was slower than I’d like, the marquee didn’t disappear for seconds while the GPU was catching up.

I finally solved the problem as much as possible by using an ATI Radeon HD3650 AGP 4X/8X which supports OpenGL 2.0, DirectX 10.1 and Shader Model 4.0. I am using the latest beta drivers and have had a couple blue-screens in the display driver in a couple weeks, but generally the card works ok on my ancient system to run things like CS4 and Aero and AutoPanoGiga.

Related Discussion Topics

Nice and short text about related topics in discussion sections