Photoshop CS3 freezes on edit > preferences > performance

RH
Posted By
Rory_Hill
Mar 15, 2008
Views
538
Replies
15
Status
Closed
I have been having performance problems with photoshop CS3, where all types of activities become slower and slower. I tried to open the edit > preferences > performance dialog and this causes photoshop to freeze and eventually become "not responding" every time.

Is this a known issue? I have not been able to find any reference in my searches. I have updated the latest patch to CS3.

Here is my system info:

Adobe Photoshop Version: 10.0.1
Computer: DellXPS710
Video: Nvidia GeForce 8600 GTS and Nvidia GeForce 7900GS Operating System: (Vista home premium)
System architecture: Intel CPU Family:6, Model:15, Stepping:7 with MMX, SSE Integer, SSE FP, SSE2 Physical processor count: 4
Processor speed: 2394 MHz
Built-in memory: 2813 MB
Free memory: 1515 MB
Memory available to Photoshop: 1659 MB
Memory used by Photoshop: 55 %
Image cache levels: 6
Application folder: C:\Program Files\Adobe\Adobe Photoshop CS3\ Temporary file path: C:\Users\Rory\AppData\Local\Temp\
Photoshop scratch has async I/O enabled
Scratch volume(s):
K:\, 465.8G, 452.8G free

What I have tried so far:

– Uninstall, run CS3clean script at level 1, reinstall CS3 – I have only one printer installed, no network printers – Turn McAffee off (I think – it seems complicated to turn off) – Confirmed I have the latest nVidia drivers
– Turned file indexing off on the scratch drive
– Run in safe start mode – THIS WORKED. As you can see in the specs I moved the scratch drive while in safe start mode, but this did not help.

Therefore I appear to have a conflict somewhere. All my other software, including Lightroom and Bridge are working fine.

If anyone has any suggestions I would be most grateful.

Rory

Must-have mockup pack for every graphic designer 🔥🔥🔥

Easy-to-use drag-n-drop Photoshop scene creator with more than 2800 items.

CY
curt_young
Mar 17, 2008
This is a common problem with Bridge, a file gets corrupted. One has to hold down Ctrl as soon as icon clicked to start Bridge. A menu will come up with 3 options. Reset preferences seems to fix it. Probably same solution for CS3.
RH
Rory_Hill
Mar 17, 2008
Thanks for the help Curt. Holding Ctrl down does not do anything when starting photoshop on my machine. I tried resetting bridge just in case – no difference.

Although I did not document it in my first post, I did delete the preferences file which resets the preferences in photoshop apparently. This did not help.

Also, in msconfig, I have turned off all startup items and system services, to no avail. Photoshop still freezes when I try Edit > Preferences > Performance.

I am going to test my memory next.

Also, I would like to see if the nvidia drivers are causing the problem, but I do not know how to turn them off and use a generic video driver. If anyone can help of this please advise.

Rory
MD
Michael_D_Sullivan
Mar 17, 2008
Try holding down Ctrl+Alt+Shift, instead — immediately after double clicking the Bridge icon.
JJ
John_Joslin
Mar 17, 2008
Try holding down Ctrl+Alt+Shift…

Does that work for you Michael? I tried it 100 times for Bridge before I realised that it was necessary to hold down Ctrl (only!) until the dialog came up. Like many things in Bridge it took quite a while.
RH
Rory_Hill
Mar 17, 2008
Try holding down Ctrl+Alt+Shift, instead — immediately after double clicking the Bridge icon.

Thanks for the tip Michael. Perhaps I was not clear. I have no problems with Bridge, and was able to reset it, using the Ctrl trick, but this did not solve my PHOTOSHOP problem.
MD
Michael_D_Sullivan
Mar 18, 2008
I’ve actually never had to trash the Bridge preferences. I didn’t know about Ctrl-only, and assumed the preference reset was the same as in Photoshop.
JJ
John_Joslin
Mar 18, 2008
I never had to either but I like to try things I’m recommending to others. It’s so easy to get the dialog with other Adobe applications, I wondered why I was having such a problem with Bridge until I picked that tip up in the Bridge forum.
RH
Rory_Hill
Mar 19, 2008
Update – I have isolated the problem. I am running three monitors on two nvidia cards. When I run only one monitor (disable the other two) then photoshop runs fine. When I enable a second monitor then photoshop fails. There is a conflict between the nvidia multi-monitor support and photoshop. I do not see this porblem with any other software.
DM
dave_milbut
Mar 19, 2008
There is a conflict between the nvidia multi-monitor support and photoshop

nview? nope, works ok w/2 monitors. try resetting the photoshop preferences per the faq first.
RH
Rory_Hill
Mar 20, 2008
nview? nope, works ok w/2 monitors. try resetting the photoshop preferences per the faq first

Hi Dave – thanks for the tip.

As I mentioned in what I have tried so far, I did reset the photoshop preferences and this did not work.

I have nview setup for three monitors, two 20" viewsonics in portrait mode and a 30" dell in portrait mode. I can pick any nview mode and I still get the photoshop issue.

If I set the nview display mode to "Only use one display" and I go to display settings in vista and disable the second and third monitor then photoshop works properly.
DM
dave_milbut
Mar 20, 2008
As I mentioned in what I have tried so far, I did reset the photoshop preferences and this did not work.

you didn’t mention that. reread your post. maybe i’m missing it.

here’s how to reset them: <http://www.adobeforums.com/webx/.ef4a07f/1>

Run in safe start mode – THIS WORKED. As you can see in the specs I moved the scratch drive while in safe start mode, but this did not help. Therefore I appear to have a conflict somewhere. All my other software, including Lightroom and Bridge are working fine.

while a pain the the butt, you might want to consider disabling everything in msconfig (start> run> msconfig) and then work up from there, re-enabling and rebooting until you recreate the problem. like i said, it’s a pain, but you should be able to isolate the conflict.
RH
Rory_Hill
Mar 21, 2008
As I mentioned in what I have tried so far, I did reset the photoshop
preferences and this did not work.

you didn’t mention that. reread your post. maybe i’m missing it.

Hi Dave

Try reading post #2 and #8 ;^) As you can see, I have already tried all your suggestions, and isolated the problem to either nview or the nvidia driver. But I very much appreciate your time and help.

When I have time this weekend I will try to search for other nvidia / photoshop conflicts.
DM
dave_milbut
Mar 21, 2008
what card and what driver version? and what nview version? i’ll check mine later and report back. i might be a version or two back from the latest.
RA
Richard_Abbott
Apr 15, 2008
I have this problem (CS3 freezes when attempting to edit performance preferences) with a single ASUS 3850 (ATI) graphics board. I am running VISTA 32bit OS and latest video driver.
LV
Largo_V
May 15, 2008
I have exactly the same problem with :
– Vista 32
– XPS 710
– 2 graphic cards (8800 GTX & 6800 GS)
– 3 screens

How to Master Sharpening in Photoshop

Give your photos a professional finish with sharpening in Photoshop. Learn to enhance details, create contrast, and prepare your images for print, web, and social media.

Related Discussion Topics

Nice and short text about related topics in discussion sections