66.7% Zoom Max’s Out CPU Usage

MS
Posted By
Mike_Sargent
Jan 22, 2009
Views
471
Replies
11
Status
Closed
I’ve notice this before but never quantified it, if I open a shot at say 4000×3000 pxs in CS4, all is normal, however, when I zoom to 66.7% the CPU usage jumps to 80-90% and remains there. At all other zoom levels CPU usage is as low as expected, this seems to apply to any file format and is totally repeatable.

System Specs:
Design Premium CS4
Vista Home Premium SP1 (32 Bit)
4gb Ram
Dual Core E6750
2 Internal Hard Disks (250/500 Gb / 164/411 free) Scratch disk on Drive D Nvidia 8600GT 256Mb
Memory Usage In Prefs set @ 70% – 1151MB (default)

Has anybody else experienced this?
BC
Bart_Cross
Jan 22, 2009
No.
RK
Rob_Keijzer
Jan 22, 2009
You should be able to see which processes keep the processor busy.

Rob
MS
Mike_Sargent
Jan 22, 2009
Rob

It’s photoshop.exe

If photoshop is minimised whilst this occuring, cpu usage jumps down to normal levels again.
RK
Rob_Keijzer
Jan 22, 2009
Beats me. I checked it just now, and the act of zooming ups the activity a bit (4%) but then drops back to zero.

Layered 16 bit file, approx 200 MB
XPpro SP3
PS CS4
Q6600

BTW, maybe PS is "fighting" with something. A/V scratch vs Windows page file.

Do you also get this at the other "odd" zoom levels?

Rob
MS
Mike_Sargent
Jan 22, 2009
Rob

I’ve just checked again and using the navigator to zoom, I’m getting the problem at 33.33%, 66.67 and now 100%. I can also replicate it at various manually entered zoom amounts from 65 -108%.

I tried again by disabling my AV (Kaspersky Internet Security 7) and this didn’t make any difference.

Maybe something is ‘fighting’ with PS – While typing this, I just tried turning OpenGL off and restarting – The problem goes away. So I guess this is another one of those performance issues that hopefully will be fixed in the maintenance release. Re-starting OpenGL brings the problem back.
RK
Rob_Keijzer
Jan 22, 2009
Mike,

That means IMO (I’m a photographer, not a computer expert) that your main processor is forced to do the soft screen mapping, in stead of the GPU taking care of that.

Try this: re-enable OpenGL in preferences, but switch off everything under the Advanced button (in Preferences > Performance).

Rob
MS
Mike_Sargent
Jan 22, 2009
Rob

Thanks

Done that, still no difference, strange it does it for only certain size images e.g. 4000 x 3000 pixels , doesn’t seem to happen to smaller ones. I wonder if the 256 MB graphics card is large enough to handle the image properly?

Strange though, some the zoom levels that were pulling high CPU usage are now ok – 66.67% still no good.

Playing with some of the other OpenGL settings (turning on Verical Sync, 3D Image Acceleration & Force Bilinear Inertpolation, I can reduce the CPU usage to around 60%
RK
Rob_Keijzer
Jan 22, 2009
Mike,

Maybe the (old) video card driver doesn’t know how to fulfil the demands that PS makes.

Anyway, it’s just the processor. If nothing else is impaired, let the bugger work. Tell it that the entire world went through a singularity the past 30 years to reach this level, so it might as well co-operate.

🙂

Rob
MS
Mike_Sargent
Jan 22, 2009
Rob

At this rate I’m going to disappear through a singularity and up my own existence!

Thanks for your help
SK
Stefan_Klein
Jan 22, 2009
Mike,

it happens on my PC as well! 66,66% zoom level and CPU usage goes up. Q 6600, 4GB, Geforce8600GT/512MB, Vista 32 Ultimate.

Stefan
MS
Mike_Sargent
Jan 23, 2009
Stefan

I was beginning to feel all alone in the world, at least somebody else can reproduce the problem!

Related Discussion Topics

Nice and short text about related topics in discussion sections