How do I input Japanese text?

TS
Posted By
Tybee_Saltfur
Nov 5, 2003
Views
5245
Replies
9
Status
Closed
Okay, let’s not have any responses here that are asking more questions than I’m getting answers for, and let’s stick strictly to doing what I want to do inside of Photoshop. Now, here’s the problem:

I am trying to create a very simple Photoshop image with some Japanese characters. (For those of you who can’t help but ask, I’m using the ENGLISH version of Photoshop 7.) I have no problem getting Japanese characters to appear inside of Word, Wordpad, Mozilla, Internet Explorer, or almost every other possible document editor I have. Unfortunately, Photoshop seems lacking in the ability to paste and show Japanese characters into the images I want. All I get are dots.

Now, the question. How do I make Photoshop display Japanese characters with the text tool? If someone out there knows how to accomplish this, please let me know as soon as possible. Thank you!

Powered by Creative Market

SB
Scott_Byer
Nov 5, 2003
Change the font to a font containing J characters before pasting.

-Scott
TS
Tybee_Saltfur
Nov 5, 2003
I have already done that. Unfortunately, it does not work. I still get dots no matter what font I choose. I do know a J font, or one with embedded J characters, is installed due to the fact I can get the text to show up in everything else.
G
Gener
Nov 5, 2003
What version of Windows do you have?

If it is 2000/XP…you will need to set the system default language to Japanese for proper handling of Japanese text between applications.

If it is Windows 95/98/Me I would use JWPce, a freeware Japanese text editor that allows you to select a copy/paste format that Photoshop understands.
SB
Scott_Byer
Nov 6, 2003
Or upgrade to Photoshop CS, which definitely handles Unicode cut and paste very well (I was pretty sure I had fixed that for Photoshop 7. Hmm. What if you paste into Notepad and then re-copy from that?)

-Scott
TS
Tybee_Saltfur
Nov 6, 2003
I’m using Windows 98 with no option of upgrade right now, unfortunately. The computer I have pretty much sucks. Notepad doesn’t have Unicode support so all that appears are question marks. I tried and it doesn’t work. It seems I may have to spend mucho moolah for CS just so I can put in Japanese characters in one or two small images the way I want them. *sigh*
G
Gener
Nov 6, 2003
Thanks Tybee, now I have enough to proceed with something that will work. I used to input Japanese characters under Windows 98. It can be done.

I mentioned a freeware text editor, JWPce. You can get it at:

<http://www.physics.ucla.edu/~grosenth/jwpce.html>

Download and install. You input your Japanese text into it, no IME neccesary. Under the Utilities menu, select "options" and File/clipboard. Try Unicode as the export, or any of the other formats, then proceed with the copy and paste from JWP into the Type Tool.

If you buy Photoshop CS, it won’t install under W98 anyway.

PS7 is perfectly Japanese capable…it’s an OS problem.

Gene–
TS
Tybee_Saltfur
Nov 7, 2003
You probably won’t believe this. I was toying around with something on a slight hunch you and Scott gave me. Turns out it’s not an operating system issue. It’s an odd problem within PS7, or at least it is on Windows 98. I selected MS Gothic for the font and the pasted the Japanese text. It suddenly showed up. The only thing different was that the text tool’s anti-aliasing option was set to something other than "none." It turns out that PS7 won’t display Japanese text with the text tool unless the anti-aliasing is turned on.
TS
Tybee_Saltfur
Nov 7, 2003
I just posted a response to another forum-goer here in regards to the Japanese text issue in PS7 under Windows 98. I selected MS Gothic first as the font, then pasted the text. Lo and behold, it showed up! The only thing I found different that time around was that the text’s anti-aliasing was turned on. I ran several scenarios, including shutting down Photoshop and restarting it, copying different things, trying different fonts first, etc. The singlemost thing that affects this is the anti-aliasing tool. If it’s set to "none", then the Japanese text will simply show up as little dots. I do not know if this is a bug or something in relation to the operating system, but I figured out the cause thanks to a hunch you gave me. Thanks for your help!
G
Gener
Nov 7, 2003
Well, glad it was that simple. I tried the same settings in PS7 under Windows 2000 and see no problems here.

But at least…that logjam is cleared. 🙂

Related Discussion Topics

Nice and short text about related topics in discussion sections