CS4 Slooooow

DS
Posted By
David_Stamps
Dec 16, 2008
Views
359
Replies
8
Status
Closed
I would appreciate some technical help. Although generally I have the same complaint as others re vastly slower cs4 over cs3, it seems like the solutions are not generic. Almost every operation crawls whether resizing 800×600 pixel image or 200x100px path. Also the Min-Max icons often get mixed up, move, indent without doing anything.

So here is my system configuration:
Dell Precision 690
Dual Xeon dual core CPU’s 5140 – 2.33gz
4 gb memory with /3gb switch set.
ATI FireGL v7200 dual head adapter
Latest Driver: v. 8.293.0.0 9/8/2006
Kaspersky Workstation AV v.6.0
2 Sata Drives with 200 gb free space on C:
O/S XP SP3
Direct X 9.0c – no errors on check.
Photoshop v.11 – Extended.

Thanks,

Powered by Creative Market

CF
chris_farrell
Dec 16, 2008
Put the cache up to 7 or 8 restart PS and see if that helps…maybe allocate ram to 75%….

…..and obviously, set the scratch on a separate physical drive ( not partition ). Ideally you would want the windows page file on a separate physical disk too ( some may say that’s overkill )…they need loads of space to function properly.

I have personally found the CS4 x64 version to have a significant increase in speed in every aspect once you go through the fine tuning ( it’s not the same as CS3 so requires a different approach )…as well as the extra RAM increase benefits….that really helps. But you may have to go to Vista for that. Also, ‘Xeons’, server processors aren’t great for Photoshop – they’re stable, YES, but not faster than your normal Dual Cores /Quad Cores – I have a q9650 and it flies.
DS
David_Stamps
Dec 16, 2008
Thanks for the input.
Boosting cache levels does have some improvement.
Memory allocation doesn’t as much. Moved it to D drive where it now resides with the primary VM file.

x64 or Vista are not an option in this year’s budget.
Still the irritating problem with the min/max buttons moving around.
P
ProArtist
Dec 17, 2008
There really isnt anything you can do. Adobe is looking into it and hopefully they will provide a solution sooner rather than later.

Its a Photoshop issue.
CC
Chris_Cox
Dec 17, 2008
Things to try:

Disable Kaspersky (known to have caused problems for a few people) Disable or remove all third party plugins (the icons sound like a known bug in plugins) Update your video card drivers (known to have caused endless headaches) Update DirectX (may apply only to Vista)

Many of the performance problems reported have been due to external factors.
SK
Stefan_Klein
Dec 17, 2008
Chris, how can I update Direct X on Vista? Vista already has DX10. Is there a newer version?
DE
David_E_Crawford
Dec 17, 2008
Vista has DX10 but it is also uses DX 9c for other programs. You can find the Decembers DX 9c on the DX webpage. If you have Vista SP1 you also have DX 10.1 Version. Except for a small percent of games DX 10 and 10.1 versions are not really used.
P
ProArtist
Dec 17, 2008
In my case, AntiVirus, Drivers, etc … none of them had anything to do with the slow down. The slow down seems to be because I was running on a 30inch monitor at 2560×1600 on a GF 8800GTX.

If i zoomed 100%, photoshop would lag, editing color curves was ridiculously slow at 100% zoom, the stamp tool and healing tool were almost unusable due to a very delayed input when picking the clone source region. However… If I zoomed out to less 33%, photoshop was pretty smooth.

I can run apps just fine at that resolution, including opengl apps such as Softimage XSI, BodyPaint 3D and mudbox. And i know they’re doing far more complicated things than PS. So where is the problem? Zbrush (I know its not an opengl App) is doing far more on the cpu than PS and its lightning smooth at 2560×1600.

The only problem was PS CS4. It just cant handle running at a large resolution.

My Trial has run out but everything pointed to PS not performing… while everything else ran fine.

The only real reason i could find that would improve performance was zooming out from a picture. But thats not acceptable for everyones workflow.

CS3 outperforms CS4 by a HUGE margin at 2560×1600 resolution.
JJ
John Joslin
Dec 17, 2008
Anti-virus my be the cause of some isolated slow-downs but quite a few have confirmed that it has no ill-effects.

I thought right at the beginning of your problems that the 30" screen was a a factor. I’m sure its a lovely thing to have but even if I could afford it I wouldn’t go above 24". Why, 19" used to be considered huge!

Related Discussion Topics

Nice and short text about related topics in discussion sections